My AEG toaster doesn't work

Issue

  • Toaster doesn't work

Applies to

  • AEG AT7800-U

Resolution

1. Check the power supply of the device for a defect before using the device:

  • If the cable is damaged, do not use the device any more.
  • Contact customer service immediately on the phone number AEG - 03445 611 611 - consumer.services.uk@aeg.com
  • Check the outlet with another device such as a kettle.
  • Check whether the fuse in the plug needs to be changed.
  • Malfunctions caused by disregarding the operating instructions are excluded from the guarantee.

Cause

  • Lack of maintenance

Was this article helpful?

Find your User Manual

Solve problems and find instructions and other documentation for your product.

Find manual

Book a repair

Need to arrange a repair technician visit? Repairs under warranty are free of charge and we are here to support you after your warranty has expired. Authorised Technicians and genuine parts for complete peace of mind.

Book service