Robotic vacuum cleaner displays the wrong time
Resolution
Issue:
- Robotic vacuum cleaner displays the wrong time
Applies to:
- Pure i9 series robotic vacuum cleaner
- RX9 series robotic vacuum cleaner
Resolution:
1. Make sure the robotic vacuum is connected to the internet and wait until it receives the correct time.
- If it does not correct time within 24 hrs, reconnect the robotic vacuum cleaner.
- Follow the instruction on the phone app or in the user manual. Download .
Cause:
- The robot has not received updated time from the server.
Was this article helpful?
Related Articles
- Updating the smart phone app
- Robotic vacuum stops while running, with no lights, error message or the display is blank
- Robotic vacuum starts to clean just a specific part of the room
- Robotic vacuum doesn’t charge or doesn't seem to finish charging
- If the robotic vacuum gets stuck (under the bed, between the chairs)
- My robotic vacuum cleaner shows error code E17
- Will the clock settings be saved after exchanging batteries or when the robotic vacuum cleaner was not charged for a longer time period?
- Will I need to use another vacuum cleaner apart from the robotic vacuum?
- Where can I buy accessories (filters, brushes, battery packs, spare parts) for my robotic vacuum?
- Robotic vacuum main brush is not working well